ospf 路由策略配置
- 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
- 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
- 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
A B
B路由器和A路由器之间运行OSPF协议,B路由器通过OSPF发布三条静态路由到A路由器,静态路由的目的网段为5.5.5.5,6.6.6.6,7.7.7.7,类型为第一类外部路由,A路由器学到的5.5.5.5.的cost值比6.6.6.6和7.7.7.7的cost值小。配置如下:
B路由器
router id 2.2.2.2
#
interface Ethernet4/2/0
ip address 11.11.11.12 255.255.255.0
#
acl number 1
rule 0 permit source 5.5.5.5 0
#
acl number 2
rule 0 deny source 5.5.5.5 0
rule 1 permit
#
ospf
import-route static cost 100 type 1 route-policy cost
#
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 11.11.11.0 0.0.0.255
#
route-policy cost permit node 10
if-match acl 1
apply cost 10
route-policy cost permit node 20
if-match acl 2
#
ip route-static 5.5.5.5 255.255.255.255 NULL 0 preference 60
ip route-static 6.6.6.6 255.255.255.255 NULL 0 preference 60
ip route-static 7.7.7.7 255.255.255.255 NULL 0 preference 60
#
A路由器配置:
router id 1.1.1.1
!
interface Ethernet3/1/0
ip address 11.11.11.11 255.255.255.0
!
interface LoopBack1/0/0
ip address 1.1.1.1 255.255.255.255
!
router ospf
network 1.1.1.1 0.0.0.0 area 0.0.0.0
network 11.11.11.0 0.0.0.255 area 0.0.0.0
!
end
在路由器A使用show ip route查看路由表如下:
Routing Tables:
Destination/Mask Proto Pre Metric Nexthop Interface
1.1.1.1/32 Direct 0 0 127.0.0.1 InLoopBack0
2.2.2.2/32 OSPF 10 1563 11.11.11.12 Ethernet3/1/0
5.5.5.5/32 O_ASE 150 11 11.11.11.12 Ethernet3/1/0
6.6.6.6/32 O_ASE 150 101 11.11.11.12 Ethernet3/1/0
7.7.7.7/32 O_ASE 150 101 11.11.11.12 Ethernet3/1/0 11.11.11.0/24 Direct 0 0 11.11.11.11 Ethernet3/1/0 11.11.11.11/32 Direct 0 0 127.0.0.1 InLoopBack0
在路由策略中使用acl访问列表,默认的是deny all,
如果路由器上使能防火墙,即firewall enable,系统缺省的是permit all,