常用网络设备配置命令与配置实例
- 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
- 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
- 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
常用网络设备配置命令及配置实例
计算机命令:
PCA login: root ;使用root用户 password: linux ;口令是linux
# shutdown -h now ;关机
# init 0 ;关机
# logout
# login
# ifconfig ;显示IP地址
# ifconfig eth0 <ip address> netmask <netmask> ;设置IP地址
# ifconfig eht0 <ip address> netmask <netmask> down ; 删除IP地址
# route add 0.0.0.0 gw <ip>
# route del 0.0.0.0 gw <ip>
# route add default gw <ip> ;设置网关
# route del default gw <ip> ;删除网关
# route ;显示网关
# ping <ip>
# telnet <ip> ;建立telnet之前先ping一下
^^^^^^^^^^^^^^^^^^^^^^^^^^^^路由器^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
显示命令:
router#show run ;显示接口
router#show interface ;显示接口
router#show ip route ;显示路由
router#show cdp nei ;看邻居
router#reload ;重新起动
设置口令:
router>enable ;进入特权模式
router#config terminal ;进入全局配置模式
router(config)#hostname <hostname> ;设置交换机的主机名
router(config)#enable secret xxx ;设置特权加密口令为 xxx router(config)#enable password xxx ;设置特权非密口令为 xxx router(config)#line console 0 ;进控制台口(Rs232)初始化router(config-line)#line vty 0 4 ;进入虚拟终端virtual tty router(config-line)#login ;允许登录
router(config-line)#password xx ;设置登录口令xx
router(config)# (Ctrl+z) ; 返回特权模式
router#exit ;返回命令
配置IP地址:
router(config)#int s0/0 ;进行串Serail接口
router(config-if)#no shutdown ;起动接口
router(config-if)#clock rate 64000 ;设置时钟
router(config-if)#ip address 10.1.1.1 255.255.0.0 ;设置IP地址和子网掩码router(config-if)#ip add 10.1.1.2 255.255.0.0 second;
router(config-if)#int f0/0.1 ; 进入子接口
router(config-subif.1)#ip address <ip><netmask> ;
router(config-subif.1)#encapsulation dot1q <n> ;
router(config)#config-register 0x2142 ;跳过配置文件
router(config)#config-register 0x2102 ;正常使用配置文件
router#reload ;重新引导
复制操作:
router#copy running-config startup-config ;存配置
router#copy running-config tftp ;上载
router#copy startup-config tftp
router#copy t: ;特权模式下升级IOS
router#copy t ;下载配置文件到nvram
ROM状态:
Ctrl+Break ;进入ROM监控状态rommon>confreg 0x2142 ;跳过配置,26 36 45xx rommon>confreg 0x2102 ;使用配置,恢复工作状态rommon>reset ;重新引导,等效于重开机rommon>copy xmodem:<sname> flash:<dname> ;从console升级IOS
rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码rommon>T ;指定TFTP服务器IP
rommon>T ;所要下载的文件
rommon>t ;ROM监控状态下升级IOS rommon>dir flash: ;查看闪存中的内容rommon>boot ;引导IOS
静态路由:
ip route <ip-address> <subnet-mask> <gateway> 例:
router(config)#ip route 10.1.0.0 255.255.0.0 10.2.1.1
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2
动态路由:
router(config)#ip routing ;启动路由
router(config)#router rip ;启动RIP路由协议。
router(config-router)#network <netid> ;配置范围,有的支持all。
router(config-router)#negihbor <ip-address> ;点对点帧中继用。
帧中继命令:
router(config)# frame-relay switching ;使能帧中继交换
router(config-s0)# encapsulation frame-relay ;使能帧中继
router(config-s0)# frame-relay intf-type DCE ;DCE端(需要配虚电路) router(config-s0)# frame-relay local-dlci 20 ;配置虚电路号
基本访问控制列表:
router(config)#access-list <number> permit|deny <source ip> <wild|any>
router(config)#interface <interface>
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^交换机^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^显示命令:
switch#write ;写入保存
switch#show vtp
switch#show run ;查看当前配置信息
switch#show vlan ;看VLAN
switch#show interface ;显示所有端口信息
switch#show int f0/0 ;显示端口0的信息
交换机基本状态:
switch: ;ROM状态, 路由器是rommon>
hostname> ;用户模式
hostname# ;特权模式
hostname(config)# ;全局配置模式
hostname(config-if)# ; 接口状态
交换机口令设置:
switch>enable ;进入特权模式
switch#config terminal ;进入全局配置模式
switch(config)#hostname <hostname> ;设置交换机的主机名
switch(config)#enable secret xxx ;设置特权加密口令为 xxx switch(config)#enable password xxx ;设置特权非密口令为 xxx switch(config)#line console 0 ;进控制台口(Rs232)初始化switch(config-line)#line vty 0 4 ;进入虚拟终端virtual tty switch(config-line)#login ;允许登录
switch(config-line)#password xx ;设置登录口令xx
switch#exit ;返回命令
交换机VLAN设置:
switch#vlan database ;进入VLAN设置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;删vlan 2
switch(config)#int f0/1 ;进入端口1
switch(config-if)#switchport access vlan 2 ;当前端口1加入VLAN 2 switch(config-if)#switchport mode trunk ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
switch(config)#vtp domain <name> ; 设置发vtp域名
switch(config)#vtp password <word>
switch(config)#vtp mode server
switch(config)#vtp mode client
交换机设置IP地址:
switch(config)#interface vlan 1 ;进入vlan 1 switch(config-if)#ip address <IP> <mask> ;添加远程登录IP switch(config)#ip default-gateway <IP> ;添加默认网关switch#dir flash: ;查看内存
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^实例^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^观察路由器启动流程,确认路由器IOS版本号和硬件信息
察看在User EXEC模式下能够执行的命令
在Privileged EXEC模式下执行以下命令,观察并解释执行结果
1. show version
2. show processes cpu
3. show protocols
4. show interfaces
5. show flash
6. show startup-config
7. show running-config
8. show ip route
9. show mem
命令行编辑
1. <Ctrl><A> 移动到命令行开头
2. <Ctrl><E> 移动到命令行结束
3. <ESC><B> 移动到上一个词开始
4. <Ctrl><F> 移动到前一个字符
5. <Ctrl><B> 移动到下一个字符
6. <ESC><F> 移动到下一个词
配置路由器识别信息
1. hostname
2. banner motd
3. description
密码设定
主控台密码
line con 0
password abc
虚拟终端密码
line vty 0 4
password abc
特权模式密码
enable secret abc
确认一个界面状态
1. interface ethernet 0
2. show interface ethernet 0
3. shutdown
4. no shutdown
保存配置
1. write memory
2. copy running-config startup-config
3. copy running-config tftp
从tftp服务器载入配置
1. copy t
2. copy t
密码恢复
1. 在路由器启动过程中 Break
2. 更改过程
〈 Cisco 2600系列〉
a) rommon>confreg
b) Do you wish to change the configuration?y/n[n]:y
c) Enable “ignore system config info”?[y/n]n:y
d) Change the boot characteristics?[y/n][n]:y
e) Enter to boot: 2
f) Do you wish to change the configuration?y/n[n]:n
g) rommon>reset
h) Would you like to enter the initial dialog?[yes]:no
i) enable
j) configure memory
k) 改密码
l) config-register 0x2102
CDP协议
1. cdp run
2. cdp timer
3. cdp holdtime
4. show cdp neighbors
简单一点的实例
Route> 你进来是这个样子
Route>en 打个en回车进入特权模式
Route# 特权模式就是这个样子
Router#conf t 打个conf t回车进入全局配置模式
Enter configuration commands, one per line. End with CNTL/Z. 这个是自动显示出来的,别打
Router(config)# 全局配置模式就是这个样子
Router(config)#hostname R1 第一项配置:把2600路由器改个名如R1
R1(config)# 现在名字叫r1 了
R1(config)#exit 打这个就退出全局配置模式了
%SYS-5-CONFIG_I: Configured from console by console
R1#show run 打这个就看配置了
Building configuration...
Current configuration : 510 bytes
!
version 12.2
no service password-encryption
!
hostname R1
!!
ip ssh version 1
!!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
下面一大堆就不显示了,
第二项配置:端口配ip
R1#conf t 应该熟悉了,进入到全局配置模式
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface FastEthernet0/0 进入端口f0/0 准备进行IP配置,这个端口你可以在2600面板上找到标有fastethernet 0/0的端口,现在就是要给它分配个IP地址。
R1(config-if)#ip add 192.168.1.1 255.255.255.0 这个就是给它配ip了。
(add是address 的简称)。
R1(config-if)#no sh 这个是up端口
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
这个时候你拿台电脑,连上配好的口
电脑的ip 配 192.168.1.2 255.255.255.0
路由器上的灯该闪了,路由器界面上会显示类似
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up 的信息。
配到这,你在电脑上ping 192.168.1.1 是通的。
路由器各端口编号说明
下图是Cisco 2610路由器端口编号的示意图,详细说明请参考路由器说明书。
二、例子
(参照“中国网通新建工程网管和路由器IP分配表”)
例如:南宁路由器的设置如下
Router#configure t
Router(config)# interface f 0/0 ------------------------------------配端口IP地址
Router(config-if)#ip address 132.37.77.1 255.255.255.0
Router(config-if)#shut
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#interface s0/0
Router(config-if)#ip address 10.1.27.2 255.255.255.0
Router(config-if)#shut
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#interface s0/1
Router(config-if)#ip address 10.1.28.2 255.255.255.0
Router(config-if)#shut
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router ospf 100 ------------------------------------ 配路由协议
Router(config-router)# router-id 132.37.77.1 --------IP地址是以太网口的IP Router(config-router)#no capability opaque
Router(config-router)#network 10.1.27.0 0.0.0.255 area 10.18.0.0
Router(config-router)#network 10.1.28.0 0.0.0.255 area 10.18.0.0
Router(config-router)#network 132.37.77.0 0.0.0.255 area 10.18.0.0
Router(config-router)#exit
Router(config)#exit
Router#wri -------------------------------------保存配置
结束设置。