网络设备安装与调试chp12路由重分布实验指导

合集下载
  1. 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
  2. 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
  3. 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。

路由重分布配置1.实验目的
通过本实验可以掌握:
(1)路由重分布概念
(2)种子度量值概念
(3)各种路由协议的默认种子度量值
(4)重分布进RIP
(5)重分布进EIGRP
(6)重分布进OSPF
2.实验拓扑
实验拓扑如图所示。

3.实验步骤
R1(config)#interface Serial0/0
R1(config-if)# ip address 172.16.12.1 255.255.255.0 R1(config-if)# no shu
R1(config-if)# clock rate 128000
R1(config-if)#exit
R1(config)#ip route 192.168.1.0 255.255.255.0 Null0 R1(config)#router rip
R1(config-router)# version 2
R1(config-router)# redistribute static metric 3
R1(config-router)# network 172.16.0.0
R1(config-router)# no auto-summary
R2(config-if)# ip address 172.16.12.2 255.255.255.0 R2(config-if)# no shut
R2(config-if)#exit
R2(config)#interface Serial0/1
R2(config-if)# ip address 172.16.23.2 255.255.255.0 R2(config-if)# clock rate 128000
R2(config-if)# no shut
R2(config-if)#exit
R2(config)#router eigrp 1
R2(config-router)# redistribute rip metric 100000 100 255 1 1500
R2(config-router)# network 172.16.23.2 0.0.0.0
R2(config-router)# no auto-summary
R2(config-router)#exit
R2(config)#router rip
R2(config-router)# version 2
R2(config-router)# redistribute eigrp 1
R2(config-router)# network 172.16.0.0
R2(config-router)# default-metric 6
R2(config-router)# no auto-summary
R2(config-router)#exit
R3(config-if)# ip address 172.16.34.3 255.255.255.0
R3(config-if)# clock rate 128000
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#
R3(config)#interface Serial0/1
R3(config-if)# ip address 172.16.23.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router eigrp 1
R3(config-router)# redistribute ospf 1 metric 1000 100 255 1 1500
R3(config-router)# network 172.16.23.3 0.0.0.0
R3(config-router)# distance eigrp 90 150
R3(config-router)# no auto-summary
R3(config-router)#exit
R3(config)#router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# redistribute eigrp 1 metric 30 metric-type 1 subnets R3(config-router)# network 172.16.34.3 0.0.0.0 area 0
====================================================================== R4(config)#interface Loopback0
R4(config-if)# ip address 172.16.0.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface Loopback1
R4(config-if)# ip address 172.16.1.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface Loopback2
R4(config-if)# ip address 172.16.2.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface Loopback3
R4(config-if)# ip address 172.16.3.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface Loopback4
R4(config-if)# ip address 172.16.4.4 255.255.255.0
R4(config-if)# exit
R4(config-if)#interface Loopback44
R4(config-if)# ip address 44.4.4.4 255.255.255.0
R4(config-if)# exit
R4(config-if)#interface Loopback199
R4(config-if)# ip address 172.16.199.4 255.255.255.0
R4(config-if)# exit
R4(config-if)#interface Loopback200
R4(config-if)# ip address 172.16.200.4 255.255.255.0
R4(config-if)# exit
R4(config)#interface Serial0/0
R4(config-if)# ip address 172.16.34.4 255.255.255.0
R4(config-if)#exit
R4(config)#access-list 1 permit 172.16.0.0 0.0.254.0
R4(config)#access-list 2 permit 172.16.1.0 0.0.254.0
R4(config)#
R4(config)#route-map CONN permit 10
R4(config-route-map)# match ip address 1
R4(config-route-map)# set metric 200
R4(config-route-map)# set metric-type type-2
R4(config-route-map)#exit
R4(config)#route-map CONN permit 20
R4(config-route-map)# match ip address 2
R4(config-route-map)# set metric-type type-1
R4(config-route-map)#exit
R4(config)#route-map CONN permit 30
R4(config-route-map)#exit
R4(config)#router ospf 1
R4(config-router)# router-id 4.4.4.4
R4(config-router)#redistribute maximum-prefix 6 50 warning-only R4(config-router)# redistribute connected subnets route-map CONN R4(config-router)# network 172.16.34.4 0.0.0.0 area 0
4. 实验调试
R1#show ip route
172.16.0.0/24 is subnetted, 7 subnets
R 172.16.34.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0 R 172.16.23.0 [120/1] via 172.16.12.2, 00:00:12, Serial0/0 C 172.16.12.0 is directly connected, Serial0/0
R 172.16.0.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0 R 172.16.1.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0 R 172.16.2.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0 R 172.16.3.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0
S 192.168.1.0/24 is directly connected, Null0
44.0.0.0/24 is subnetted, 1 subnets
R 44.4.4.0 [120/6] via 172.16.12.2, 00:00:12, Serial0/0
R2#show ip route
172.16.0.0/24 is subnetted, 7 subnets
D EX 172.16.34.0 [170/3097600] via 172.16.23.3, 00:23:09, Serial0/1 C 172.16.23.0 is directly connected, Serial0/1
C 172.16.12.0 is directly connected, Serial0/0
D EX 172.16.0.0 [170/3097600] via 172.16.23.3, 00:12:11, Serial0/1 D EX 172.16.1.0 [170/3097600] via 172.16.23.3, 00:12:11, Serial0/1 D EX 172.16.2.0 [170/3097600] via 172.16.23.3, 00:12:11, Serial0/1 D EX 172.16.3.0 [170/3097600] via 172.16.23.3, 00:12:11, Serial0/1 R 192.168.1.0/24 [120/3] via 172.16.12.1, 00:00:15, Serial0/0
44.0.0.0/24 is subnetted, 1 subnets
D EX 44.4.4.0 [170/3097600] via 172.16.23.3, 00:10:27, Serial0/1
R3#show ip route
172.16.0.0/24 is subnetted, 7 subnets
C 172.16.34.0 is directly connected, Serial0/0
C 172.16.23.0 is directly connected, Serial0/1
D EX 172.16.12.0 [150/2195456] via 172.16.23.2, 00:23:37, Serial0/1 O E2 172.16.0.0 [110/200] via 172.16.34.4, 00:12:39, Serial0/0
O E1 172.16.1.0 [110/84] via 172.16.34.4, 00:12:39, Serial0/0
O E2 172.16.2.0 [110/200] via 172.16.34.4, 00:12:39, Serial0/0
O E1 172.16.3.0 [110/84] via 172.16.34.4, 00:12:39, Serial0/0
D EX 192.168.1.0/24 [150/2195456] via 172.16.23.2, 00:23:37, Serial0/1
44.0.0.0/24 is subnetted, 1 subnets
O E2 44.4.4.0 [110/20] via 172.16.34.4, 00:10:55, Serial0/0
R4#show ip route
172.16.0.0/24 is subnetted, 7 subnets
C 172.16.34.0 is directly connected, Serial0/0
O E1 172.16.23.0 [110/94] via 172.16.34.3, 00:13:07, Serial0/0
O E1 172.16.12.0 [110/94] via 172.16.34.3, 00:13:07, Serial0/0
C 172.16.0.0 is directly connected, Loopback0
C 172.16.1.0 is directly connected, Loopback1
C 172.16.2.0 is directly connected, Loopback2
C 172.16.3.0 is directly connected, Loopback3
O E1 192.168.1.0/24 [110/94] via 172.16.34.3, 00:13:07, Serial0/0
44.0.0.0/24 is subnetted, 1 subnets
C 44.4.4.0 is directly connected, Loopback44
route-map CONN, permit, sequence 10
Match clauses:
ip address (access-lists): 1
Set clauses:
metric 200
metric-type type-2
Policy routing matches: 0 packets, 0 bytes
route-map CONN, permit, sequence 20
Match clauses:
ip address (access-lists): 2
Set clauses:
metric-type type-1
Policy routing matches: 0 packets, 0 bytes
route-map CONN, permit, sequence 30
Match clauses:
Set clauses:
Policy routing matches: 0 packets, 0 bytes
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Default redistribution metric is 6
Redistributing: rip, eigrp 1
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0 2 2 Serial0/1 2 2 Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.12.1 120 00:00:06
Distance: (default is 120)
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: rip, eigrp 1
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.23.2/32
Routing Information Sources:
Gateway Distance Last Update
172.16.23.3 90 00:12:08
Distance: internal 90 external 170
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 3.3.3.3
It is an autonomous system boundary router
Redistributing External Routes from,
eigrp 1 with metric mapped to 30, includes subnets in redistribution Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.16.34.3 0.0.0.0 area 0
Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
4.4.4.4 110 00:12:50
Distance: (default is 110)
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: ospf 1, eigrp 1
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.23.3/32
Routing Information Sources:
Gateway Distance Last Update
172.16.23.2 90 00:25:32
Distance: internal 90 external 150。

相关文档
最新文档