aux端口
- 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
- 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
- 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
一般做实验时,一般都用serial口来连接两台路由器,但要哪一天,你的serial口用完了怎么办呢?别着急,其实你还可以使用aux口,运用PPP来连接两台路由器。
我们知道,一般路由器都会带个aux口,接口类型有两种,一种是RJ45(比如25系列,26系列等),还有一种就是DB25(比如45系列,7000系列等);aux属于DTE设备,所以两个DTE 设备相连就需要用到反转线(rollover);如果两端都是RJ45的,那就直接用一根反转网线相连;如果两端是DB25,那就要用到RJ45-DB25的转换头中间连接一个反转线,或直接做一根两头都是DB25头的线,线的连接顺序如下:
DB25 DB25
RxD23TxD
TxD32RxD
CTS45RTS
RTS54CTS
DTR620CD
DSR820CD
CD206DTR
CD208DSR
GND77GND
拓扑图见上。
配置如下:
Router 1
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.0.1 255.255.255.0
encapsulation ppp
async default routing
async mode dedicated
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1 logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 4
login
!
end
------------------------------------------------- Router 2
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.0.2 255.255.255.0 encapsulation ppp
async default routing
async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1 logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 4
login
!
end
如果出现问题,如何调试呢?可以使用如下命令来查看:show line
show line aux 0
shutdown和no shutdown来开始和重制aux口的状态debug ppp negotiation 查看ppp的状态。