在路由器上实现UDP包转发
合集下载
相关主题
- 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
- 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
- 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
Sniffer pro
实验地点
上海旗盈科技(Cisco实验基地)实验室
实验步骤
1RouterA是划分在A网段,RouterB划分在B网段,AB路由器是通过Serial0连接。
2RouterA的以太口Ethernet与集线器HubA连接。RouterB的以太口Ethernet与集线器HubB连接。
3Expedition服务器与加密狗服务器安装在Server上,Server与HubA连接。Expedition客户端安装在Client上,Client与HubB连接。
10从VLAN3上能ping通VLAN2中的192.168.1.2;从VLAN4上能ping通VLAN2中的192.168.1.2;
show run
Building configuration...
Current configuration : 1797 bytes
!
version 12.1
no service pad
ip helper-address 192.168.1.2
!
interface Vlan4
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.2
4RouterA-Ethernet0 IP地址192.168.1.1 255.255.255.0;
5RouterA-Serial0 IP地址192.168.2.1 255.255.255.0;
6RouterB-Ethernet0 IP地址192.168.3.1 255.255.255.0;
7RouterB-Serial0 IP地址192.168.2.2 255.255.255.0;
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
cns event-service server!
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
2接口FastEthernet0/11划分成VLAN2;
3接口FastEthernet0/12划分成VLAN3;
4接口FastEthernet0/13划分成VLAN4;
5VLAN2接到Server上,IP地址192.168.1.1,255.255.255.0。
6VLAN3接到Client上,IP地址192.168.2.1 255.255.255.0;
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
在Server上安装Expedition服务器explvxn。启动explvxn;
在Server上安装加密狗驱动程序和服务程序。启动superproserver;
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.1.1 255.255.255.0
!Байду номын сангаас
interface Vlan3
ip address 192.168.2.1 255.255.255.0
正常情况下,在路由器上转发Server上的UDP 6001
现象:在客户端上运行expedition客户端,启动速度较慢。
原因:在广播找加密狗,广播信息通过路由器,到达加密狗服务器上。
结论:UDP信息通过Csico路由器的Forward之后,还是UDP信息,不是TCP。
现象:Expedition客户端能正常启动运行。在服务器端上启动的Snifferpro上能发
7VLAN4接到Client上,IP地址192.168.3.1 255.255.255.0;
8Server的IP地址为192.168.1.2 255.255,255,0,在VLAN2中。
9Client的IP地址为192.168.3.2 255.255.255.0,在VLAN4中;也可以让Client的IP地址为192.168.2.2 255.255.255.0,在VLAN3中;
实验一在路由器上实现UDP包转发
(注:本文由圣天诺网络加密锁客户-上海普华公司资深技术工程师吕小妮提供,特此感谢)
实验名称
在路由器上实现UDP包的转发。
实验目的
1测试Expedition加密狗的广播信息是否能通过路由器到达不同网段,从而实现Expedition软件的跨网段安装。
2跟踪Expedition数据包的转发过程。
PC机二台
加密狗一只
网线及控制线若干
软件:
Cisco IOS Version 12.1(5)T10
Expedition program
Sentinel super pro net driver and service
Sniffer pro
实验地点
上海旗盈科技(Cisco实验基地)实验室
实验步骤
1SwitchA划分VLAN;
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
现象:在客户端上运行expedition客户端,软件提示“A running sentinel server can not
be found”。
原因:客户端上的在寻加密狗时,发出的广播信息不能被有效返回,而在另一个网
段的加密狗服务程序是正常启动的。
结论:在路由器上不转发Server上的UDP6001,Expedition不能正常运行。
1在Server上启动Sniffer pro;
2在Server上启动ExpLvxn;
3在Server上启动Superproserver服务;
4在Client上启动Sniffer pro;
5在Client上启动Expedition客户端;
6分析结果;
非正常情况下,在路由器上不转发Server上的UDP6001
路由器B的配置
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
1在Server上启动Sniffer pro;
2在Server上启动ExpLvxn;
3在Server上启动Superproserver服务;
4在Client上启动Sniffer pro;
5在Client上启动Expedition客户端;
6分析结果;
㈡非正常情况下,在路由器上不转发Server上的UDP6001
实验二在三层交换机上实现UDP包转发
实验名称
在三层交换机上实现UDP包的转发。
实验目的
1测试Expedition加密狗的广播信息是否能通过三层交换机划分的VLAN,从而实现Expedition软件跨VLAN的访问。
2跟踪Expedition数据包的转发过程。
实验器材
硬件:
路由器Cisco 3550一台
no ip address
shutdown
!
ip kerberos source-interface any
ip classless
ip forward-protocol udp 6001(在全局模式下配置)
ip route 192.168.1.0 255.255.255.0 192.168.2.1
no ip address
!
interface FastEthernet0/13
switchport access vlan 4
no ip address
!
.
.
.
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
enable password cisco
!
ip subnet-zero
no ip finger
!
cns event-service server
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
ip helper-address 192.168.1.2(在端口局部模式下配置)
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
!
interface Serial1
no ip address
shutdown
!
interface TokenRing0
现下图所示的UDP数据信息,这个信息包是从192.168.3.2上来的,数据源端
口为6001。
原因:寻找加密狗的UDP信息能正常通过路由器。
结论:在路由器上转发Server上的UDP 6001,Expedition软件能实现跨网段安装。
实验结论
在路由器上的expedition客户端的端口上配置接收UDP信息的地址,在路由器全局模式下配置转发UDP 6001,Expedition软件能实现跨网段安装。有几个网段的用户要使用Expedition软件,就需要在路由器上几个相应的端口上配置接收UDP信息的地址。
实验器材
硬件:
路由器Cisco 2513一台
路由器Cisco2514一台
交换机Cisco2900二台
PC机二台
加密狗一只
网线及控制线若干
软件:
Cisco IOS Version 12.1(5)T10
Expedition program
Sentinel super pro net driver and service
!
!
interface FastEthernet0/1
no ip address
!
.
.
.
interface FastEthernet0/11
switchport access vlan 2
no ip address
!
interface FastEthernet0/12
switchport access vlan 3
8Server的Ethernet0 IP地址192.168.1.2 255.255.255.0;
9Client的Ethernet0 IP地址192.168.3.2 255.255.255.0;
10从Client上能ping通192.168.1.2;
路由器A的配置
version 12.1
no service single-slot-reload-enable
no ip address
shutdown
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
clockrate 2000000
!
interface Serial1
no ip address
shutdown
!
ip kerberos source-interface any
在Server上安装Sniffer pro;
在Client上安装Expedition上客户端;
在Client上配置NSP_HOST参数;(参见Expedition安装手册中跨网段的安装说明)
在Client上安装Sniffer pro;
在上述条件具备的情况下,执行如下操作:
㈠正常情况下,在路由器上转发Server上的UDP 6001
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3550
!
!
ip subnet-zero
ip routing
!
!
spanning-tree extend system-id
service timestamps log uptime
no service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
Sniffer pro
实验地点
上海旗盈科技(Cisco实验基地)实验室
实验步骤
1RouterA是划分在A网段,RouterB划分在B网段,AB路由器是通过Serial0连接。
2RouterA的以太口Ethernet与集线器HubA连接。RouterB的以太口Ethernet与集线器HubB连接。
3Expedition服务器与加密狗服务器安装在Server上,Server与HubA连接。Expedition客户端安装在Client上,Client与HubB连接。
10从VLAN3上能ping通VLAN2中的192.168.1.2;从VLAN4上能ping通VLAN2中的192.168.1.2;
show run
Building configuration...
Current configuration : 1797 bytes
!
version 12.1
no service pad
ip helper-address 192.168.1.2
!
interface Vlan4
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.2
4RouterA-Ethernet0 IP地址192.168.1.1 255.255.255.0;
5RouterA-Serial0 IP地址192.168.2.1 255.255.255.0;
6RouterB-Ethernet0 IP地址192.168.3.1 255.255.255.0;
7RouterB-Serial0 IP地址192.168.2.2 255.255.255.0;
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
cns event-service server!
!
interface Ethernet0
ip address 192.168.3.1 255.255.255.0
2接口FastEthernet0/11划分成VLAN2;
3接口FastEthernet0/12划分成VLAN3;
4接口FastEthernet0/13划分成VLAN4;
5VLAN2接到Server上,IP地址192.168.1.1,255.255.255.0。
6VLAN3接到Client上,IP地址192.168.2.1 255.255.255.0;
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end
在Server上安装Expedition服务器explvxn。启动explvxn;
在Server上安装加密狗驱动程序和服务程序。启动superproserver;
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.1.1 255.255.255.0
!Байду номын сангаас
interface Vlan3
ip address 192.168.2.1 255.255.255.0
正常情况下,在路由器上转发Server上的UDP 6001
现象:在客户端上运行expedition客户端,启动速度较慢。
原因:在广播找加密狗,广播信息通过路由器,到达加密狗服务器上。
结论:UDP信息通过Csico路由器的Forward之后,还是UDP信息,不是TCP。
现象:Expedition客户端能正常启动运行。在服务器端上启动的Snifferpro上能发
7VLAN4接到Client上,IP地址192.168.3.1 255.255.255.0;
8Server的IP地址为192.168.1.2 255.255,255,0,在VLAN2中。
9Client的IP地址为192.168.3.2 255.255.255.0,在VLAN4中;也可以让Client的IP地址为192.168.2.2 255.255.255.0,在VLAN3中;
实验一在路由器上实现UDP包转发
(注:本文由圣天诺网络加密锁客户-上海普华公司资深技术工程师吕小妮提供,特此感谢)
实验名称
在路由器上实现UDP包的转发。
实验目的
1测试Expedition加密狗的广播信息是否能通过路由器到达不同网段,从而实现Expedition软件的跨网段安装。
2跟踪Expedition数据包的转发过程。
PC机二台
加密狗一只
网线及控制线若干
软件:
Cisco IOS Version 12.1(5)T10
Expedition program
Sentinel super pro net driver and service
Sniffer pro
实验地点
上海旗盈科技(Cisco实验基地)实验室
实验步骤
1SwitchA划分VLAN;
ip classless
ip route 192.168.3.0 255.255.255.0 192.168.2.2
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
现象:在客户端上运行expedition客户端,软件提示“A running sentinel server can not
be found”。
原因:客户端上的在寻加密狗时,发出的广播信息不能被有效返回,而在另一个网
段的加密狗服务程序是正常启动的。
结论:在路由器上不转发Server上的UDP6001,Expedition不能正常运行。
1在Server上启动Sniffer pro;
2在Server上启动ExpLvxn;
3在Server上启动Superproserver服务;
4在Client上启动Sniffer pro;
5在Client上启动Expedition客户端;
6分析结果;
非正常情况下,在路由器上不转发Server上的UDP6001
路由器B的配置
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
1在Server上启动Sniffer pro;
2在Server上启动ExpLvxn;
3在Server上启动Superproserver服务;
4在Client上启动Sniffer pro;
5在Client上启动Expedition客户端;
6分析结果;
㈡非正常情况下,在路由器上不转发Server上的UDP6001
实验二在三层交换机上实现UDP包转发
实验名称
在三层交换机上实现UDP包的转发。
实验目的
1测试Expedition加密狗的广播信息是否能通过三层交换机划分的VLAN,从而实现Expedition软件跨VLAN的访问。
2跟踪Expedition数据包的转发过程。
实验器材
硬件:
路由器Cisco 3550一台
no ip address
shutdown
!
ip kerberos source-interface any
ip classless
ip forward-protocol udp 6001(在全局模式下配置)
ip route 192.168.1.0 255.255.255.0 192.168.2.1
no ip address
!
interface FastEthernet0/13
switchport access vlan 4
no ip address
!
.
.
.
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
enable password cisco
!
ip subnet-zero
no ip finger
!
cns event-service server
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
ip helper-address 192.168.1.2(在端口局部模式下配置)
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
!
interface Serial1
no ip address
shutdown
!
interface TokenRing0
现下图所示的UDP数据信息,这个信息包是从192.168.3.2上来的,数据源端
口为6001。
原因:寻找加密狗的UDP信息能正常通过路由器。
结论:在路由器上转发Server上的UDP 6001,Expedition软件能实现跨网段安装。
实验结论
在路由器上的expedition客户端的端口上配置接收UDP信息的地址,在路由器全局模式下配置转发UDP 6001,Expedition软件能实现跨网段安装。有几个网段的用户要使用Expedition软件,就需要在路由器上几个相应的端口上配置接收UDP信息的地址。
实验器材
硬件:
路由器Cisco 2513一台
路由器Cisco2514一台
交换机Cisco2900二台
PC机二台
加密狗一只
网线及控制线若干
软件:
Cisco IOS Version 12.1(5)T10
Expedition program
Sentinel super pro net driver and service
!
!
interface FastEthernet0/1
no ip address
!
.
.
.
interface FastEthernet0/11
switchport access vlan 2
no ip address
!
interface FastEthernet0/12
switchport access vlan 3
8Server的Ethernet0 IP地址192.168.1.2 255.255.255.0;
9Client的Ethernet0 IP地址192.168.3.2 255.255.255.0;
10从Client上能ping通192.168.1.2;
路由器A的配置
version 12.1
no service single-slot-reload-enable
no ip address
shutdown
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
clockrate 2000000
!
interface Serial1
no ip address
shutdown
!
ip kerberos source-interface any
在Server上安装Sniffer pro;
在Client上安装Expedition上客户端;
在Client上配置NSP_HOST参数;(参见Expedition安装手册中跨网段的安装说明)
在Client上安装Sniffer pro;
在上述条件具备的情况下,执行如下操作:
㈠正常情况下,在路由器上转发Server上的UDP 6001
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3550
!
!
ip subnet-zero
ip routing
!
!
spanning-tree extend system-id