Cisco PPPoE配置实例
- 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
- 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
- 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
实验配置:
1、ADSL PPPoE Client 配置
第一种方法:用PC上创建PPPOE客户端。
第二种方法:用CISCO路由器的以太口进行PPPOE拨号:非固定IP
配置模板:
en
confit t
vpdn enable
vpdn-group pppoe
request-dialin
protocol pppoe
exit
exit
interface ethernet 0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shutdown //把接口打开
exit
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
ppp pap sent-username walkbird password walkbird
dialer pool 1
ip router 0.0.0.0 0.0.0.0 dialer1
2、用cisco路由器做PPPoE Server端配置
en
conf t
hostname Adsl_walkbird
username walkbird password walkbird
vpdn enable
vpdn-group pppoe
accept-dialin
protocol pppoe
virtual-template 1
exit
exit
interface ethernet 0/0
pppoe enable
no shutdown
interface virtual-template 1
mtu 1492 //PPP头部最大传输单元
ip unnumbered loopback //借用地址
peer default ip address pool pppoe_ip_pool
encapsulation ppp
ppp authentication pap
exit
ip local pool pppoe_ip_pool 11.11.11.10 11.11.11.100
interface lookback0
ip address 1.1.1.1 255.255.255.0
no shutdown
exit
三、实验测试
sh ip route
sh ip int brief
debug pppoe event
sh ip int dialer 1
Cisco1841路由器连接ADSL modem的PPPoE配置
案例一
vpdn enable
no vpdn logging
!
!
interface Ethernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip mroute-cache
!
!
!
!
interface Ethernet0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip nat outside
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap
ppp pap sent-username dg48907653@163.gd password xxxxxxxx
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
exec-timeout 0 0
transport input none
line vty 0 4
login
!
end
案例二
经典思科1841ADSL的成功设置+DHCP的问题~!急~~!
路由器下面的客户端全是XP。都是设为自动获取IP 地址。
现像是在客户端上IPCONFIG 地址是0。0。0。0
没有获得指定的IP地址,
系统也没有获得169网段的地址。
cisco1841#sh run
Building configuration...
Current configuration : 2970 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service dhcp
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi
pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
ip dhcp database 123
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
ip dhcp ping packets 0
!
ip dhcp pool 123
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 202.106.0.20 202.106.46.151
!
!
no ip domain lookup
ip domain name
ip dhcp-server 192.168.1.1
vpdn enable
vpdn ip udp ignore checksum
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
!
username cisco privilege 15 secret 5 $1$ZKUk$YoVcdG31aDaIAn/mdK9qL0
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 192.168.1.1 255.255.255.0
ip access-group 100 in
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip access-group 100 in
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer vpdn
dialer-group 1
no cdp enable
ppp pap sent-username 1234567 password 0 1234567
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
ip http authentication local
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
access-list 100 deny
access-list 100 deny
access-list 100 permit ip any any
dialer-list 1 protocol ip permit
!
control-plane
!
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this
device.
This feature requires the one-time use of the username "cisco"
with the password "cisco".
Please change these publicly known initial credentials using SDM or the
IOS CLI.
Here are the Cisco IOS commands.
username
no username cisco
Replace
want to use.
For more information about SDM please follow the instructions in the
QUICK START
GUIDE for your router or go to /go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
timeout login response 200
login local
line aux 0
line vty 0 4
timeout login response 200
privilege level 15
password gbicc_cisco
login
transport input telnet
line vty 5 15
privilege level 15
password gbic_cisco
login
transport input telnet
!
end
cisco1841#
案例三
假设E0接内网,E1接ADSL上外网
第一步:配置vpdn
vpdn enable(启用路由器的虚拟专用拨号网络---vpnd)
vpdn-group office(建立一个vpdn组,)
request-dialin(初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)
protocol pppoe(vpdn子组使用pppoe建立会话隧道)
第二步: 配置路由器连接adsl modem的接口
interface Ethernet1
no ip address
pppoe enable允许以太接口运行pppoe
ppp
oe-client dial-pool-number 1将以太接口的pppoe拨号客户端加入拨号池1
第三步:配置逻辑拨号接口:
interface Dialer1
ip address negotiated从adsl服务商动态协商得到ip地址
ip nat outside为该接口启用NAT
encapsulation ppp为该接口封装ppp协议
dialer pool 1该接口使用1号拨号池进行拨号
dialer-group 1该命令对于pppoe是意义不大的
ppp authentication pap callin启用ppp pap验证
ppp pap sent-username xxxxxxx password 0 yyyyyyy使用已经申请的用户名和口令
第四步:配置内部网络接口
interface Ethernet0(内部网络接口)
ip address 10.1.1.1 255.255.255.0
ip nat inside为该接口启用NAT
第五步:配置路由器为内部网络主机提供dhcp服务
ip dhcp excluded-address 10.1.1.1
ip dhcp pool ABC
import all(导入dns和wins server)
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
第六步:配置NAT:
access-list 1 permit 10.1.1.0 0.0.0.255
ip nat inside source list 1 interface Dialer1 overload
第七步:配置缺省路由
ip route 0.0.0.0 0.0.0.0 Dialer1