利用BGP虚拟下一跳技术实现IP骨干网流量负载均衡

合集下载
  1. 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
  2. 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
  3. 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。

配置说明:

【R1】

interface Loopback0

ip address 192.168.0.1 255.255.255.255

interface Serial1/0

no sh

ip address 172.16.15.1 255.255.255.0

interface Serial1/1

no sh

ip address 172.16.12.1 255.255.255.0

interface Serial1/2

no sh

ip address 172.16.16.1 255.255.255.0

interface Serial1/3

no sh

ip address 172.16.13.1 255.255.255.0

ip route 10.0.0.1 255.255.255.255 172.16.13.3 【虚拟下一跳地址指向真正下一跳,并由本域内IGP(OSPF)路由引入,使本域内所有邻居都能学习到虚拟下一跳地址的路由,从而使邻居从自己学习到的路由能最优化】

ip route 192.168.0.3 255.255.255.255 172.16.13.3

ip prefix-list ISP-B seq 5 permit 172.16.34.0/24【做前缀列表匹配需要改变下一跳的前缀】

route-map set-nexthop permit 10 【做route-map,改相应前缀下一跳性】

match ip address prefix-list ISP-B

set ip next-hop 10.0.0.1

route-map set-nexthop permit 20

router ospf 1

router-id 192.168.0.1

no auto-cost

redistribute static metric 10 metric-type 1 subnets【引入静态路由,使域内所有IBGP邻居能学到虚拟下一跳地址,从面使邻居从自己学习到的路由能最优化】

network 172.16.12.0 0.0.0.255 area 0

network 172.16.15.0 0.0.0.255 area 0

network 172.16.16.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 0

router bgp 100

no synchronization

bgp router-id 192.168.0.1

bgp log-neighbor-changes

neighbor internal peer-group

neighbor internal remote-as 100

neighbor internal update-source Loopback0

neighbor internal route-map set-nexthop out【做出方向的ruout-map改变发向邻居路由的下一跳】

neighbor 192.168.0.2 peer-group internal

neighbor 192.168.0.3 remote-as 200

neighbor 192.168.0.3 ebgp-multihop 255

neighbor 192.168.0.3 update-source Loopback0

neighbor 192.168.0.3 soft-reconfiguration inbound

neighbor 192.168.0.5 peer-group internal

neighbor 192.168.0.6 peer-group internal

no auto-summary

【R2】

interface Loopback0

ip address 192.168.0.2 255.255.255.255

interface Serial1/0

no sh

ip address 172.16.26.2 255.255.255.0

interface Serial1/1

no sh

ip address 172.16.12.2 255.255.255.0

interface Serial1/2

no sh

ip address 172.16.25.2 255.255.255.0

interface Serial1/3

no sh

ip address 172.16.24.2 255.255.255.0

ip route 10.0.0.1 255.255.255.255 172.16.24.4【虚拟下一跳地址指向真正下一跳,并由本域内IGP(OSPF)路由引入,使本域内所有邻居都能学习到虚拟下一跳地址的路由,从而使邻居从自己学习到的路由能最优化】

ip route 192.168.0.4 255.255.255.255 172.16.24.4

ip prefix-list ISP-B seq 5 permit 172.16.34.0/24【做前缀列表匹配需要改变下一跳的前缀】

route-map set-nexthop permit 10【做route-map,改相应前缀下一跳性】

match ip address prefix-list ISP-B

set ip next-hop 10.0.0.1

route-map set-nexthop permit 20

router ospf 1

router-id 192.168.0.2

log-adjacency-changes

no auto-cost

redistribute static metric 10 metric-type 1 subnets【引入静态路由,使域内所有IBGP邻居能学到虚拟下一跳地址,从面使邻居从自己学习到的路由能最优化】

相关文档
最新文档