杭州电子科技大学acm答案

合集下载
  1. 1、下载文档前请自行甄别文档内容的完整性,平台不提供额外的编辑、内容补充、找答案等附加服务。
  2. 2、"仅部分预览"的文档,不可在线预览部分如存在完整性等问题,可反馈申请退款(可完整预览的文档不适用该条件!)。
  3. 3、如文档侵犯您的权益,请联系客服反馈,我们会尽快为您处理(人工客服工作时间:9:00-18:30)。
temp=n; n=m;m=temp; } for(i=n;i<=m;i++) { if(i%2==0) s2+=i*i;
else s1+=i*i*i; } cout<<s2<<" "<<s1<<endl; } return 0;
} 题解:输入的两个区间 大小不一定
2008 数值统计
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20378 Accepted Submission(s): 10783
正确代码:
#include<iostream> #include<cmath> #include<iomanip> #define PI 3.1415927 using namespace std; int main() {
double r,v; while(cin>>r) { v=4*PI*r*r*r/3;
Problem Description
统计给定的 n 个数中,负数、零和正数的个数。
Input
输入数据有多组,每组占一行,每行的第一个数是整数 n(n<100),表示需要统计的数值的个数,然 后是 n 个实数;如果 n=0,则表示输入结束,该行不做处理。
Output
对于每组输入数据,输出一行 a,b 和 c,分别表示给定的数据中负数、零和正数的个数。
Sample Input
6 0 1 2 3 -1 0 5 1 2 3 4 0.5 0
Sample Output
123 005 正确代码: #include<iostream> using namespace std; int main() {
int n; double m; while(cin>>n) {
using namespace std;
int main()
{
int m,n,s; while(scanf("%x%x",&m,&n)!=EOF) //以十六进制输入
{
s=m+n; printf("%d\n",s);
//以十进制输出,与上面
}
return 0;
} 此题的输入输出没有用 cin>> 和 cout<<,看到很多人说 scanf 和 printf 比较常用
cin>>k; s+=k; } if(i==n-1) { cout<<s<<endl; } else { cout<<s<<endl<<endl; } } return 0; }
A+B Coming
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 902 Accepted Submission(s): 456
根据输入的半径值,计算球的体积。
Input
输入数据有多组,每组占一行,每行包括一个实数,表示球的半径。
Output
输出对应的球的体积,对于每组输入数据,输出一行,计算结果保留三位小数。
Sample Input
1 1.5
Sample Output
4.189 14.137
Hint
#define PI 3.1415927
Sample Input
3123 42345
Sample Output
3 15
正确代码: #include<iostream> using namespace std; int main() {
int n,m,i,s; // int j;
while(cin>>n) { s=1;
for(i=0;i<n;i++) { cin>>m; // j=0; if(m%2!=0) //{ s=s*m; // j++; // } } //if(j==0) //s=0; cout<<s<<endl; } return 0; } 注意:题目中已经说” 你可以假设每组数据必定至少存在一个奇数。”所以就没有必要再列出没有一
Problem Description
给定一个日期,输出这个日期是该年的第几天。
Input
输入数据有多组,每组占一行,数据格式为 YYYY/MM/DD 组成,具体参见 sample input ,另外,可以 向你确保所有的输入数据是合法的。
Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
Problem Description
Many
classmates
said
to
me
that
A+B
is
must
If you can’t AC this problem, you would invite me for night meal. ^_^
needs.
Input
Input may contain multiple test cases. Each case contains A and B in one line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
杭电 2000~
A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5573 Accepted Submission(s): 2058
2001ASCII 码排序
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 32853 Accepted Submission(s): 13545
}
2002 计算球体积
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33845 Accepted Submission(s): 13142
Problem Description
Problem Description
给你 n 个整数,求他们中所有奇数的乘积。
Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为 n,表示本组数据一共有 n 个, 接着是 n 个整数,你可以假设每组数据必定至少存在一个奇数。
Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
3 41234 512345 3123
Sample Output
10
15
6
正确代码: #include<iostream> using namespace std; int main() {
int m,n,i,j,s,k; cin>>n; int c[1000]; for(i=0;i<n;i++) { cin>>m; s=0; for(j=1;j<=m;j++) {
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Problem Description
输入三个字符后,按各字符的 ASCII 码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd zxc
Sample Output
Sample Input
1985/1/20 2006/3/12
Sample Output
20 71
正确代码: #include<stdio.h> int main() {
int y,m,d,i=0,s; while(scanf("%d/%d/%d",&y,&m,&d)!=EOF) { int c[13]={0,31,29,31,30,31,30,31,31,30,31,30,31}; if(y%4!=0||(y%100==0&&y%400!=0)){ //如果是平年
个奇数的情况 !
2007 平方和与立方和
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 37671 Accepted Submission(s): 10965
cout<<setiosflags(ios::fixed); cout<<setprecision(3)<<v<<endl;
} return 0; }
2005 第几天?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 27335 Accepted Submission(s): 10557












你可以认为 32 位整数足以保存结果。
Sample Input
13 25
Sample Output
4 28 20 152 正确代码: #include<iostream> using namespace std; int main() {
int n,m,i,temp; int s1,s2; while(cin>>n>>m) { s1=0,s2=0; if(n>m) {
Problem Description
给定一段连续ቤተ መጻሕፍቲ ባይዱ整数,求出他们中所有偶数的平方和以及所有奇数的立方和。
Input
输入数据包含多组测试实例,每组测试实例包含一行,由两个整数 m 和 n 组成。
Output
对于每组输入数据,输出一行,应包括两个整数 x 和 y,分别表示该段连续的整数中所有偶数的平方
eqw ads cxz
正确代码: #include<iostream> using namespace std; int main() {
char ch[1000]; while(cin>>ch) { if(ch[0]>ch[1]) swap(ch[0],ch[1]); if(ch[0]>ch[2]) swap(ch[0],ch[2]); if(ch[1]>ch[2]) swap(ch[1],ch[2]); cout<<ch[0]<<" "<<ch[1]<<" "<<ch[2]<<endl; } return 0;
红色部分为判断为平年的模板代码 c[2]=28; } s=0;
for(i=0;i <m;i++) {
s=s+c[i]; } s=s+d; printf("%d\n",s);
} return 0; }
2006 求奇数的乘积
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17640 Accepted Submission(s): 11525
A,
B
are
hexadecimal
number.
Input terminates by EOF.
Output
Output A+B in decimal number in one line.
Sample Input
19 AB ab
Sample Output
10
21
21
正确代码:
#include<iostream>
相关文档
最新文档